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• RCM3700 Prototyping Board, with a bag of accessory parts and jumpers f

• QKits QK145 Serial Temperature Sensor.

• AC adapter, 12 V DC, 1 A (included only with Application Kits sold for th
plug leading to bare leads is provided to allow overseas users to connect th
of 7.5–30 V.

• 10-pin header to DE9 programming cable with integrated 
level-matching circuitry.

• Cables and cable kits to access QK145 temperature sensor 
and serial and analog input connectors on Prototyping Board.

• Ethernet crossover cable.

• Getting Started instructions.

• Rabbit 3000 Processor Easy Reference poster.

• Registration card.

Installing and Running Dynamic C
Once the RCM3700 is connected and Dynamic C is installed as described in the preceding pages, start 
Dynamic C by double-clicking on the Dynamic C icon or by double-clicking on dcrabXXXX.exe in the 
Dynamic C root directory, where XXXX are version-specific characters.
Dynamic C uses the serial port specified during installation.

Run a Sample Program
Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. 
Press function key F9 to compile and run the program. The STDIO window will open on your PC and will 
display a small square bouncing around in a box.

Troubleshooting
If Dynamic C appears to compile the BIOS successfully, but you then receive a communication error mes-
sage when you compile and load the sample program, it is possible that your PC cannot handle the higher 
program-loading baud rate. Try changing the maximum download rate to a slower baud rate as follows.

• Locate the Serial Options dialog in the Dynamic C Options > Project Options > Communica-
tions menu. Select a slower Max download baud rate.

If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Try lowering the debugging baud rate 
as follows.

• Locate the Serial Options dialog in the Dynamic C Options > Project Options > Communica-
tions menu. Choose a lower debug baud rate.

If there are any other problems:

• Check that the RCM3700 is powered correctly — the power LED above the RESET button on the 
Prototyping Board should be lit.

• Check to make sure you are using the PROG connector, not the DIAG connector, on the programming 
cable.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the 
programming port on the RCM3700.

• Ensure that the RCM3700 module is firmly and correctly installed in its connectors on the Prototyping 
Board.

• Select a different COM port within Dynamic C. From the Options menu, select Project Options, 
then select Communications. Select another COM port from the list, then click OK. Press <Ctrl-Y> 
to force Dynamic C to recompile the BIOS. If Dynamic C still reports it is unable to locate the target sys-
tem, repeat the above steps until you locate the active COM port. 

• Check the Z-World/Rabbit Semiconductor Technical Bulletin Board at www.zworld.com/support/bb/.

• Use the Technical Support e-mail form at www.zworld.com/support/questionSubmit.shtml.

NOTE: If you purchased your RCM3700 through a distributor or through a Z-World or Rabbit 
Semiconductor partner, contact the distributor or partner first for technical support.

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to other sample programs on the supplementary 
CD-ROM and to develop your own applications. The source code for the sample programs is provided to 
allow you to modify them for your own use. Application Note AN406, Will That Be Serial or Ethernet?, 
describes the software and sample programs for this Application Kit, and is available on the supplementary 
CD-ROM.

Install
Insert the
cation Ki
the instal
then run 
root direc
any Dyna
mentary 
�

Multi-Port Serial-to-Ethernet Application Kit
Getting Started

Application Kit Contents
• Dynamic C CD-ROM, with complete product documentation on disk.

• Supplementary CD-ROM with sample programs, software, and information related to the Application Kit.

• RCM3700 module.
it Semiconductor, and Dynamic C are registered 
-World, Inc. and Rabbit Semiconductor.

or use on the Prototyping Board.

e North American market). A header 
eir own power supply with a DC output 

ing Dynamic C®

 Dynamic C CD from the Appli-
t in your PC’s CD-ROM drive. If 
lation program does not auto-start, 
the setup.exe program in the 
tory of the Dynamic C CD. Install 
mic C modules and the supple-

CD after you install Dynamic C.

http://www.zworld.com/support/bb/index.html
http://www.zworld.com/support/questionSubmit.shtml


The header pins may become bent or damaged if the pin alignment is offset, and the module will 
not work. Permanent electrical damage to the module may also result if a misaligned module is 
powered up.

Press the module’s pins firmly into the Prototyping Board socket.

2.  Connect Programming Cable
The programming cable connects the RCM3700 to the PC running Dynamic C to download programs 
and to monitor the RCM3700 module during debugging.

Be sure to use the programming cable supplied with this Application Kit—the program-
cable has blue shrink wrap around the RS-232 converter section located in the middle of 
ble. Programming cables from other Z-World or Rabbit Semiconductor kits were not 

ned to work with RCM3700 modules.

Some PCs now come equipped only with a USB port. It may be possible to use an 
2/USB converter with the programming cable supplied with the RCM3700 series 

lopment Kit. An RS-232/USB converter is available through the Z-World Web store.

ower
connections have been made, you can connect power to the Prototyping Board. 
ll transformer to 3-pin header J4 on the Prototyping Board as shown in Figure 1. The 
 be attached either way as long as it is not offset to one side.

 transformer. The LED above the RESET button on the Prototyping Board should 
M3700 and the Prototyping Board are now ready to be used.

The RESET button is provided on the Prototyping Board to allow a hardware reset with-
sconnecting power.

lopment Kits

ts sold outside North America include a header connector that may be connected to 3-
 the Prototyping Board. The red and black wires from the connector can then be con-

sitive and negative connections on your power supply. The power supply should deliver 
 at 500 mA.

er Cables and Jumpers

t crossover 
t the RJ-45 

3700 to 
n your PC. 
e sample 

w you run 
 either 
ore jump-
n header 

J2 of the RCM3700 Proto-
typing Board, or you will 
use one of the cables with 
a 10-pin header and a DE9 
connector to connect 
header J2 to either a PC or 
to the QK145 temperature 
sensor.

Additional Hardware Information
ore RCM3700 User’s Manual on the Dynamic C CD-ROM provides complete informa-

g and developing applications for the RCM3700, and includes further information on the 
 Board and an optional LCD/keypad module.

Figure 2.  Connect Other Cables and Jumpers
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Connect the 10-pin connector of the programming cable labeled PROG to header J2 on the RCM3700 
as shown in Figure 1. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the 
connector. (Do not use the DIAG connector, which is used for a normal serial connection.)

Connect the other end of the programming cable to a COM port on your PC.

The RabbitC
tion on usin
Prototyping
Hardware Connections
1.  Attach Module to Prototyping Board
Turn the RCM3700 module so that the Ethernet jack is on the left as shown in Figure 1 below. Insert 
the module’s J1 header into the TCM_SMT_SOCKET socket on the Prototyping Board. The shaded 
corner at the bottom right corner of the RCM3700 module should face the same direction as the corre-
sponding shaded corner below it on the Prototyping Board.

Figure 1.  Install the RCM3700 Module on the Prototyping Board

NOTE: It is important that you line up the pins on header J1 of the RCM3700 module exactly 
with the corresponding holes of the TCM_SMT_SOCKET socket on the Prototyping Board. 
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Hardware Connections
1.  Attach Module to Prototyping Board
Turn the RCM3700 module so that the Ethernet jack is on the left as shown in Figure 1 below. Insert 
the module’s J1 header into the TCM_SMT_SOCKET socket on the Prototyping Board. The shaded 
corner at the bottom right corner of the RCM3700 module should face the same direction as the corre-
sponding shaded corner below it on the Prototyping Board.

Figure 1.  Install the RCM3700 Module on the Prototyping Board

NOTE: It is important that you line up the pins on header J1 of the RCM3700 module exactly 
with the corresponding holes of the TCM_SMT_SOCKET socket on the Prototyping Board. 
The header pins may become bent or damaged if the pin alignment is offset, and the module will 
not work. Permanent electrical damage to the module may also result if a misaligned module is 
powered up.

Press the module’s pins firmly into the Prototyping Board socket.

2.  Connect Programming Cable
The programming cable connects the RCM3700 to the PC running Dynamic C to download programs 
and to monitor the RCM3700 module during debugging.

Connect the 10-pin connector of the programming cable labeled PROG to header J2 on the RCM3700 
as shown in Figure 1. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the 
connector. (Do not use the DIAG connector, which is used for a normal serial connection.)

Connect the other end of the programming cable to a COM port on your PC.
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NOTE: Be sure to use the programming cable supplied with this Application Kit—the program-
ming cable has blue shrink wrap around the RS-232 converter section located in the middle of 
the cable. Programming cables from other Z-World or Rabbit Semiconductor kits were not 
designed to work with RCM3700 modules.

NOTE: Some PCs now come equipped only with a USB port. It may be possible to use an 
RS-232/USB converter with the programming cable supplied with the RCM3700 series 
Development Kit. An RS-232/USB converter is available through the Z-World Web store.

3.  Connect Power
When all other connections have been made, you can connect power to the Prototyping Board. 
Connect the wall transformer to 3-pin header J4 on the Prototyping Board as shown in Figure 1. The 
connector may be attached either way as long as it is not offset to one side.

Plug in the wall transformer. The LED above the RESET button on the Prototyping Board should 
light up. The RCM3700 and the Prototyping Board are now ready to be used.

NOTE: The RESET button is provided on the Prototyping Board to allow a hardware reset with-
out disconnecting power.

Overseas Development Kits

Development kits sold outside North America include a header connector that may be connected to 3-
pin header J4 on the Prototyping Board. The red and black wires from the connector can then be con-
nected to the positive and negative connections on your power supply. The power supply should deliver 
7.5 V–30 V DC at 500 mA.

4.  Attach Other Cables and Jumpers

Use the Ethernet crossover 
cable to connect the RJ-45 
jack on the RCM3700 to 
the RJ-45 jack on your PC. 
Depending on the sample 
program and how you run 
it, you will then either 
attach one or more jump-
ers across pins on header 
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J2 of the RCM3700 Proto-
typing Board, or you will 
use one of the cables with 
a 10-pin header and a DE9 
connector to connect 
header J2 to either a PC or 
to the QK145 temperature 
sensor.

Additional Hardware Information
The RabbitCore RCM3700 User’s Manual on the Dynamic C CD-ROM provides complete informa-
tion on using and developing applications for the RCM3700, and includes further information on the 
Prototyping Board and an optional LCD/keypad module.

Figure 2.  Connect Other Cables and Jumpers
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ort Serial-to-Ethernet Application Kit
Getting Started

n Kit Contents
D-ROM, with complete product documentation on disk.

ry CD-ROM with sample programs, software, and information related to the Application Kit.

odule.

ototyping Board, with a bag of accessory parts and jumpers for use on the Prototyping Board.

Installing and Running Dynamic C
Once the RCM3700 is connected and Dynamic C is installed as descri
Dynamic C by double-clicking on the Dynamic C icon or by double-cl
Dynamic C root directory, where XXXX are version-specific characters
Dynamic C uses the serial port specified during installation.

Run a Sample Program
Use the File menu to open the sample program PONG.C, which is in t
Press function key F9 to compile and run the program. The STDIO win
display a small square bouncing around in a box.

Troubleshooting
If Dynamic C appears to compile the BIOS successfully, but you then 
sage when you compile and load the sample program, it is possible tha
program-loading baud rate. Try changing the maximum download rate

• Locate the Serial Options dialog in the Dynamic C Options > P
tions menu. Select a slower Max download baud rate.

If a program compiles and loads, but then loses target communication b
possible that your PC cannot handle the default debugging baud rate. T
as follows.

• Locate the Serial Options dialog in the Dynamic C Options > P
tions menu. Choose a lower debug baud rate.

If there are any other problems:

• Check that the RCM3700 is powered correctly — the power LED a
Prototyping Board should be lit.

• Check to make sure you are using the PROG connector, not the DI
cable.

• Check both ends of the programming cable to ensure that they are f
programming port on the RCM3700.

• Ensure that the RCM3700 module is firmly and correctly installed i
Board.

• Select a different COM port within Dynamic C. From the Options
then select Communications. Select another COM port from the 
to force Dynamic C to recompile the BIOS. If Dynamic C still report
tem, repeat the above steps until you locate the active COM port. 

• Check the Z-World/Rabbit Semiconductor Technical Bulletin Board

• Use the Technical Support e-mail form at www.zworld.com/support/q

NOTE: If you purchased your RCM3700 through a distributo
Semiconductor partner, contact the distributor or partner fir

Where Do I Go From Here?
Multi-P

Applicatio
• Dynamic C C

• Supplementa

• RCM3700 m

• RCM3700 Pr

bed in the preceding pages, start 
icking on dcrabXXXX.exe in the 
.

he Dynamic C SAMPLES folder. 
dow will open on your PC and will 

receive a communication error mes-
t your PC cannot handle the higher 
 to a slower baud rate as follows.

roject Options > Communica-

efore you can begin debugging, it is 
ry lowering the debugging baud rate 

roject Options > Communica-

bove the RESET button on the 

AG connector, on the programming 

irmly plugged into the PC and the 

n its connectors on the Prototyping 

 menu, select Project Options, 
list, then click OK. Press <Ctrl-Y> 
Z-World, Rabbit Semiconductor, and Dynamic C are registered 
trademarks of Z-World, Inc. and Rabbit Semiconductor.

• QKits QK145 Serial Temperature Sensor.

• AC adapter, 12 V DC, 1 A (included only with Application Kits sold for the North American market). A header 
plug leading to bare leads is provided to allow overseas users to connect their own power supply with a DC output 
of 7.5–30 V.

• 10-pin header to DE9 programming cable with integrated 
level-matching circuitry.

• Cables and cable kits to access QK145 temperature sensor 
and serial and analog input connectors on Prototyping Board.

sover cable.

ed instructions.

rocessor Easy Reference poster.

ard.

s it is unable to locate the target sys-

 at www.zworld.com/support/bb/.

uestionSubmit.shtml.

r or through a Z-World or Rabbit 
st for technical support.

Installing Dynamic C®

Insert the Dynamic C CD from the Appli-
cation Kit in your PC’s CD-ROM drive. If 
the installation program does not auto-start, 
then run the setup.exe program in the 
root directory of the Dynamic C CD. Install 
any Dynamic C modules and the supple-
mentary CD after you install Dynamic C.
020–0081 • 041031–A

• Ethernet cros

• Getting Start

• Rabbit 3000 P

• Registration c

If the sample program ran fine, you are now ready to go on to other sample programs on the supplementary 
CD-ROM and to develop your own applications. The source code for the sample programs is provided to 
allow you to modify them for your own use. Application Note AN406, Will That Be Serial or Ethernet?, 
describes the software and sample programs for this Application Kit, and is available on the supplementary 
CD-ROM.

http://www.zworld.com/support/bb/index.html
http://www.zworld.com/support/questionSubmit.shtml
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